No place to go: Transit headaches for TTC and GO riders

BT Toronto | posted Tuesday, Apr 17th, 2018

Transit riders not only had to cope with navigating the slushy and icy sidewalks Monday after the ice storm and continued rainfall, but also with getting to their destination.

First, on Sunday, the TTC was forced to shut down Line 3 (Scarborough RT) because of ice that built up on the third rail. Service resumed just before 7:30 a.m. on Monday.

Ahead of the Monday morning commute, the TTC also suspended subway service on Line 2 (Bloor-Danforth) between Victoria Park and Kennedy stations because of hydro issues at Warden Station. Just after 7 a.m., TTC spokesman Brad Ross tweeted that service had resumed.

There was also no subway service on Line 2 from Kipling to Jane stations due to a late-clearing work from the weekend. Service resumed just before 7:30 a.m.

Then, just when TTC riders were able to breathe a sigh of relief, three more issues popped up — two on Line 2, and one on Line 4 (Sheppard Yonge).

Around 8 a.m., the TTC said subway service was suspended on Line 2 from Woodbine to Kennedy stations due to a mechanical issue on a train at Victoria Park Station. Trains were back up and running a short time later.

And just before 8:30 a.m., subways were not running on Line 4 between Yonge-Sheppard and Bayview stations due to “loss of power.” Trains were running again an hour later.

The TTC also said riders can experience longer than normal travel times on Line 2 between Kipling and Royal York stations due to signal-related problems.

Across the GO Transit network, trains were not moving across the Milton line due to a person on the tracks. The line was reopened a short time later but with delays of up to 75 minutes. Earlier, trains on the Milton line were also running up to 40 minutes late due to a switch problem.

ttccrowd0416-768x1024

ttcplatform0416

 

Comments

  • No comments have been left yet, get the conversation started!

Leave a Comment Below

Sign in to comment.

All fields are required.

Want to embed media into your comment? Just paste in a URL in a separate paragraph to the page where you would normally view the media (like on YouTube) and it will automatically be embedded into your comment.