1. Skip to navigation
  2. Skip to content
  3. Skip to sidebar

Subway service resumes on Line 1 after five hour suspension

News Staff | posted Thursday, Jun 6th, 2019

Subway service on a major portion of Line 1 was disrupted for the better part of the afternoon Wednesday due to a damaged subway car.

Southbound service between Bloor-Yonge Station down to Union Station and northbound up to Osgoode Station was suspended around noon after power had to be cut when two trains suffered what the TTC calls damage to their power collection shoes.

Fifty-four passengers aboard the trains had to be evacuated and made the precarious walk back through the tunnel to Union station. No injuries were reported.

Frustrated commuters were left stranded in the rain waiting for information and buses to arrive.

“Not very well,” one lady tells CityNews when asked how TTC personnel were handling the situation. “There might be a shuttle bus, just go upstairs. What sort of information is that? One bus, how many people are standing here.”

“This is not the better way, there has to be another way. This happens so frequently that they really need to fix this.”

Comments

  • No comments have been left yet, get the conversation started!

Leave a Comment Below

Sign in to comment.

All fields are required.

Want to embed media into your comment? Just paste in a URL in a separate paragraph to the page where you would normally view the media (like on YouTube) and it will automatically be embedded into your comment.